Tomcat startet nicht

Diskutiere Tomcat startet nicht im Allgemeine Java-Themen Forum; Hallo! Wegen einem Problem mit Tomcat habe ich mich eigens in diesem Forum eingeloggt, weil ich nicht weiterkomme. Ich versuche Tomcat auf einer...

  1. ratatouille
    ratatouille Neues Mitglied
    Hallo!

    Wegen einem Problem mit Tomcat habe ich mich eigens in diesem Forum eingeloggt, weil ich nicht weiterkomme.
    Ich versuche Tomcat auf einer openSUSE 13.2 zu starten, aber er startet nicht.
    # env |grep java
    JRE_HOME=/usr/lib/jvm/java/jre
    JAVA_BINDIR=/usr/lib/jvm/java/bin
    JAVA_HOME=/usr/lib/jvm/java
    SDK_HOME=/usr/lib/jvm/java
    JDK_HOME=/usr/lib/jvm/java
    JAVA_ROOT=/usr/lib/jvm/java

    # java -version
    openjdk version "1.8.0_111"
    OpenJDK Runtime Environment (IcedTea 3.2.0) (suse-33.1-i386)
    OpenJDK Server VM (build 25.111-b14, mixed mode)

    workstation:/usr/local/tomcat/bin # ./startup.sh
    Using CATALINA_BASE: /usr/local/tomcat
    Using CATALINA_HOME: /usr/local/tomcat
    Using CATALINA_TMPDIR: /usr/local/tomcat/temp
    Using JRE_HOME: /usr/lib/jvm/java/jre
    Using CLASSPATH: /usr/local/tomcat/bin/bootstrap.jar:/usr/local/tomcat/bin/tomcat-juli.jar
    Tomcat started.

    # netstat -pantu |grep 8080
    ergibt kein Ergebnis. Ich finde folgendes im logfile:

    04.12.2017 22:35:07 org.apache.tomcat.util.digester.Digester startElement
    SEVERE: Begin event threw error
    java.lang.NoClassDefFoundError: org.apache.tomcat.util.modeler.ManagedBean
    ........
    Caused by: java.lang.ClassNotFoundException: javax.management.modelmbean.ModelMBeanNotificationBroadcaster not found in java.net.URLClassLoader{urls=[file:/usr/local/tomcat/lib/,file:/usr/
    local/tomcat/lib/catalina-ha.jar,file:/usr/local/tomcat/lib/tomcat-i18n-es.jar,file:/usr/local/tomcat/lib/jasper.jar,file:/usr/local/tomcat/lib/tomcat-util.jar,file:/usr/local/tomcat/lib/e
    l-api.jar,file:/usr/local/tomcat/lib/tomcat7-websocket.jar,file:/usr/local/tomcat/lib/tomcat-i18n-fr.jar,file:/usr/local/tomcat/lib/jsp-api.jar,file:/usr/local/tomcat/lib/tomcat-api.jar,fi
    le:/usr/local/tomcat/lib/annotations-api.jar,file:/usr/local/tomcat/lib/jasper-el.jar,file:/usr/local/tomcat/lib/websocket-api.jar,file:/usr/local/tomcat/lib/catalina-ant.jar,file:/usr/loc
    al/tomcat/lib/tomcat-jdbc.jar,file:/usr/local/tomcat/lib/catalina.jar,file:/usr/local/tomcat/lib/tomcat-dbcp.jar,file:/usr/local/tomcat/lib/ecj-4.4.2.jar,file:/usr/local/tomcat/lib/tomcat-
    coyote.jar,file:/usr/local/tomcat/lib/catalina-tribes.jar,file:/usr/local/tomcat/lib/tomcat-i18n-ja.jar,file:/usr/local/tomcat/lib/servlet-api.jar], parent=gnu.gcj.runtime.SystemClassLoade
    r{urls=[file:/usr/local/tomcat/bin/bootstrap.jar,file:/usr/local/tomcat/bin/tomcat-juli.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}}

    Versucht habe ich schon verschiedene Tomcat Versionen, immer das gleiche Ergebnis und die
    gleichen Fehlermeldungen.

    Hat jemand Rat für mich?

    Grüße

    Andreas
     
  2. Vielleicht helfen dir diese Grundlagen hier weiter: (hier klicken)
  3. L0oNY
    L0oNY Neues Mitglied
    Hi,

    und ich habe mich jetzt angemeldet, um dir zu helfen :)

    Du benutzt das openjdk Java, hast du mal versucht das Java von Sun, also das "normale" Java zu verwenden?

    Ein Stichwort für weitere Recherchen: update alterneatives

    mehr findest du hier: https://de.opensuse.org/Java

    Grüße
     
Die Seite wird geladen...

Tomcat startet nicht - Ähnliche Themen

Tomcat startet Anwendung nicht im Windows-Service-Modus
Tomcat startet Anwendung nicht im Windows-Service-Modus im Forum Server einrichten und konfigurieren
Tomcat startet nicht (java.net.BindException)
Tomcat startet nicht (java.net.BindException) im Forum Application Tier
Unterschied zw"per Hand" gestartetem Tomcat und pe
Unterschied zw"per Hand" gestartetem Tomcat und pe im Forum Server einrichten und konfigurieren
JDK in neuem Ordner --- In Eclipse startet Tomcat nicht mehr
JDK in neuem Ordner --- In Eclipse startet Tomcat nicht mehr im Forum IDEs und Tools
Tomcat startet nicht, Einstellungsfehler?
Tomcat startet nicht, Einstellungsfehler? im Forum Allgemeines EE
Thema: Tomcat startet nicht