Konfigurationsproblem Eclipse/JSF

Diskutiere Konfigurationsproblem Eclipse/JSF im Web Tier Forum; Hallo, ich versuche gerade verzweifelt eine JSF-Applikation mit Eclipse zu erstellen, woran ich aber bisher scheitere. Das Deployment...

  1. MissPiggy
    MissPiggy Neues Mitglied
    Hallo,

    ich versuche gerade verzweifelt eine JSF-Applikation mit Eclipse zu erstellen, woran ich aber bisher scheitere. Das Deployment funktioniert zwar, jedoch wird im Anschluss keine Webseite angezeigt, versucht habe ich es mit Glassfish und Wildfly (Glassfish gibt einen 404, Wildfly einen 403-Fehler zurück).
    Die App beruht auf einem Tutorial welches für JavaEE6 beruht, hier wird mit Dynamic Web Module 3.0 und JSF 2.0 gearbeitet, ich habe mittlerweile aber

    Die entsprechenden JSF-Bilbliotheken sind eingebunden, JSF 2.2 aktiviert.

    Das Problem tritt bereits auf wenn ich das Projekt lediglich erstelle und dann eine JSF-xhtml index-Seite nach Vorlage hinzufüge. Hänge ich die index.xhtml an die Adresse an wird die Seite (ohne JSF-Interpretation) angezeigt.
    Normalerweise arbeite ich mit Netbeans, hier lassen sich JSF-Anwendungen problemlos erstellen. Jedoch kann ich in den Configdateien (faces-config.xml, glassfish-web.xml und web.xml) keine wesentlichen Unterschiede feststellen.

    Welche zusätzlichen Einstellungen (ausser die Einstellung in den Project-Faces und die notwendigen Bibliotheken) müssen in Eclipse noch vorgenommen werden um ein JSF-Projekt anzeigen zu können ?
     
  2. Vielleicht hilft dir dieser Kurs hier weiter --> (hier klicken)
Die Seite wird geladen...

Konfigurationsproblem Eclipse/JSF - Ähnliche Themen

PrimeFaces (/ JSF) Konfigurationsproblem
PrimeFaces (/ JSF) Konfigurationsproblem im Forum Web Tier
Dependency Injection, Konfigurationsproblem
Dependency Injection, Konfigurationsproblem im Forum Application Tier
Konfigurationsproblem mit PrintWithJ2SE14Graphics.java
Konfigurationsproblem mit PrintWithJ2SE14Graphics.java im Forum Java Basics - Anfänger-Themen
mod_jk2 konfigurationsproblem
mod_jk2 konfigurationsproblem im Forum Allgemeines EE
Thema: Konfigurationsproblem Eclipse/JSF