JavaFX Problem mit IntelliJ und JavaFx 11 unter XUbuntu

Bitte aktiviere JavaScript!
Hallo,

ich habe leider ebenfalls Probleme JavaFx zum Laufen zu bringen.

Java "openjdk 11.0.3 2019-04-16"

Ich habe ein Gradle-Projekt erstellt und "build.gradle" wie hier hier beschrieben angepasst. Lediglich die Version wurde auf "11" geändert.
Code:
plugins {
    id 'application'
    id 'org.openjfx.javafxplugin' version '0.0.7'
}

group 'de.kagu'
version '1.0-SNAPSHOT'

repositories {
    mavenCentral()
}

javafx {
    version = "11.0.2"
    modules = [ 'javafx.controls' ]
}

dependencies {
    testCompile group: 'junit', name: 'junit', version: '4.12'
}

Leider erhalte ich diese Fehlermeldung:

Code:
09:06:06: Executing task 'FxMain.main()'...

> Task :compileJava
> Task :processResources NO-SOURCE
> Task :classes

> Task :FxMain.main() FAILED
Fehler: Zum Ausführen dieser Anwendung benötigte JavaFX-Runtime-Komponenten fehlen

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':FxMain.main()'.
> Process 'command '/usr/lib/jvm/java-11-openjdk-amd64/bin/java'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 5s
2 actionable tasks: 2 executed
Process 'command '/usr/lib/jvm/java-11-openjdk-amd64/bin/java'' finished with non-zero exit value 1
09:06:12: Task execution finished 'FxMain.main()'.
Die Imports von JavaFx Klassen in der Mainklasse werden allerdings fehlerlos angenommen und auch in den "External Libraries" im Projektfenster werden die JavaFx Komponenten angezeigt:

Bildschirmfoto_2019-05-15_09-17-20.png

Meine letzte Aktion war gerade noch "JAVA_HOME" korrekt zu setzen, allerdings funktionieren "normale" Javaprogramme ja problemlos.

Hat jemand noch einen Tipp?
 
A

Anzeige


Vielleicht hilft dir dieser Kurs hier weiter: (hier klicken)
Konkret musst du wohl die Kommandozeile (Runtime Configuration) anpassen und die Module noch explizit hinzufügen.
 
Es läuft!

Mein Fehler war, dass ich versucht habe wie gewohnt direkt die main() auszuführen.

Über den Gradle Task "run" funktioniert es.
 
Passende Stellenanzeigen aus deiner Region:

Neue Themen

Oben