@WebServlet wird nicht erkannt!

Hallo,

ich habe soeben alle Files von meinem Git Repository in Java EE importiert. Leider werden die Servlet Klassen nicht als solche erkannt:
Screenshot by Lightshot

Ich habe auch schon versucht eine neue Servlet Klasse im selben Ordner zu erstellen -> gleiches Problem.

Wie löse ich das?

danke
 
Zuletzt bearbeitet:
Was soll "in Java EE importiert" denn überhaupt bedeuten?

An deinem Code ist nix falsch. Wenn deine IDE die importierten packages nicht findet, dann ist an deiner Configuration offenbar irgendwas falsch. Was da schief geht, kann man anhand deines Codeschnipsels aber nicht erkennen.
Wie hast du denn die Pakete aus javax.*** deiner IDE bekannt gemacht?
 
Mit importieren meine ich "File -> Import -> Projects from Git". Es arbeiten noch weitere Leute an dem Code. Und jemand hat ein Dynamic Web Project angelegt, Servlets erstellt usw.

"Wie hast du denn die Pakete aus javax.*** deiner IDE bekannt gemacht?" - ehrlich gesagt, ich habe keine Ahnung (dachte es konfiguriert alles automatisch)
 
Zuletzt bearbeitet:
Mit importieren meine ich "File -> Import -> Projects from Git". Es arbeiten noch weitere Leute an dem Code. Und jemand hat ein Dynamic Web Project angelegt, Servlets erstellt usw.
Ja, schon klar, aber was genau du mit in Java EE importieren meinst, ist nicht klar.

"Wie hast du denn die Pakete aus javax.*** deiner IDE bekannt gemacht?" - ehrlich gesagt, ich habe keine Ahnung (dachte es konfiguriert alles automatisch)
In Java SE sind die Pakete aus javax.*** nunmal nicht enthalten. Die werden üblicherweise z.B. zusammen mit deinem verwendeten Application Server mitgeliefert. Ohne weitere Information deinerseits, etwa welchen Application Server und welche IDE du benutzt, kann man da nicht viel sagen..
 
Habe eben folgendes probiert:
Neues Static Web Prjoect erstellt, Servlet Klassen erstellt (hier funktioniert noch alles, es wird nichts rot markiert und @WebServlet wird ebenfalls erkannt und korrekt ausgeführt) danach den Tomcat Server, den ich zuvor erstellt habe gelöscht. Dann einen neuen Tomcat Server erstellt, das Projekt dem Server hinzugefügt und selbes Problem wieder. @WebServlet usw. wird wieder nicht erkannt.
 
Zuletzt bearbeitet:
Ja, schon klar, aber was genau du mit in Java EE importieren meinst, ist nicht klar.



In Java SE sind die Pakete aus javax.*** nunmal nicht enthalten. Die werden üblicherweise z.B. zusammen mit deinem verwendeten Application Server mitgeliefert. Ohne weitere Information deinerseits, etwa welchen Application Server und welche IDE du benutzt, kann man da nicht viel sagen..
Aber in Java EE sollte javax.*** doch enhalten sein. Und ich arbeite auch mit Java EE und nicht SE.
 
Passende Stellenanzeigen aus deiner Region:

Neue Themen

Oben