versions-check

Status
Nicht offen für weitere Antworten.
S

stev.glasow

Gast
kennt jemand ein tool mit dem man raus bekommt ab welcher java version mein programm lauffähig ist ?
 
N

Nobody

Top Contributor
du müsstest da alle neuerungen durchlesen die sich durch die unterschiedlichen versionen ergeben haben, aber im normalfall ist alles am jdk 1.1 lauffähig. nur bei ein paar dingen gibt es unterschiede aber die kenne ich selbst nicht so genau.

verlange von den usern einfach die neuste ob sie es dann brauchen ist dann garnich relevant
 
N

Nobody

Top Contributor
mache direkt beim link ein link auf das neuste prog. bzw wenn du einen installer nutzt packs gleich mit rein
 
S

Stefan1200

Gast
stevg hat gesagt.:
kennt jemand ein tool mit dem man raus bekommt ab welcher java version mein programm lauffähig ist ?

Ganz einfach: Installiere die Uralten Java REs und teste es :) *g*

Beim Event-Handling hat sich ab 1.1 alles geändert.

Sobald Tonausgabe oder Swing Elemente benutzt werden, kann man als Faustregel JavaRE 1.2 sagen.

Und alle Änderungen in 1.3 sind hauptsächlich Geschwindigkeit des REs und kleinere Sachen.

Ab Java 1.4 gab es dann Sachen wie die ProgressBar bei der Swing GUI (JProgressBar) oder den JSpinner.

Schon alleine aus Gründen der Geschwindigkeit sollte jeder mindestens Java 1.4.1 installiert haben. Hinweisen würde ich in der Anleitung allemal.


Falls irgendwas an meinen Sätzen falsch sein sollte, bitte korrigieren.
 
Status
Nicht offen für weitere Antworten.

Ähnliche Java Themen

Anzeige

Neue Themen


Oben