Spring-Beans nach Einbindung von SpringSecurity null

Bitte aktiviere JavaScript!
Hallo Leute,
bei einer Hausarbeit trat ein komischer Fehler auf, mit dem ich mich jetzt schon 3 Tage rumärgere.
Ich hatte eine funktionierende Webanwendung mit den Technologien Hibernate, Spring, Struts2. Nach der Einbindung von SpringSecurity sind jedoch alle Service-Beans null, so als würde die spring.xml nicht mehr gelesen werden.
SpringSecurity habe ich nicht über xml eingebunden sondern über Konfigurationsklassen. Wenn ich diese wieder entferne, läuft alles wie vorher.
Die eigentliche Konfiguration von SpringSecurity funktioniert auch wie gewollt.

Gruß
Tim
 
A

Anzeige




Vielleicht hilft dir unser Java-Tutorial hier weiter —> (hier klicken)
Tja, was soll man mit diesen Informationen da jetzt deiner Meinung nach groß zu sagen? Da machste wohl was falsch ....
 
Wenn du nicht helfen willst, schreib doch einfach nicht. Was sollte ich denn deiner Meinung nach noch mehr schreiben? Alle Klassen mit Gettern und Settern? Mehr steht da nämlich noch nicht drin. Den Stacktrace bei einer Nullpointer? Nullpointer weil Service-Bean nicht läuft, steht auch oben.
Da es sich anscheinend um ein sehr spezifisches Problem handelt, könntest du einfach nichts schreiben wenn du keine konkreten Vermutungen hast. Aber ich brauche den Post nicht unnötig aufblähen.
 
A

Anzeige




Du möchtest Python lernen? Dann sichere dir hier alle wichtigen Grundlagen.
Passende Stellenanzeigen aus deiner Region:

Neue Themen

Oben