Netbeans 11.1 - Gradel aktualisieren

Diskutiere Netbeans 11.1 - Gradel aktualisieren im IDEs und Tools Bereich.
J

Joob

Ich wollte mein Gradel aktualisieren, weil ich beim compilieren folgende Meldung bekomme.

WARNING: You use Gradle 4.10.2. The minimum version supported (with some limitations) by this plugin is 5.1. It is strongly recommended to use at least Gradle 5.6.
Project : => no module-info.java found

Leider finde ich keine Anleitung dazu.
Ich finde zwar Gradel und es scheint eine Abhängigkeit zu Groovy zu geben, aber ich weiß wirklich nicht wie ich das richtig anfassen soll.

Kann mir jemand auf die Sprünge helfen ?
 
J

Joob

In Netbeans kann ich keine Version auswählen.

1595187740427.png

Wie kann ich die geforderte oder neuste Version in Netbeans installiern ?
 
J

Joob

Ich habe jetzt auf NB 12 und java 14 aktualisiert.
Das hat zu meinem Erstaunen alles super geklappt.

Ich bekommen jetzt aber noch ein paar Fehlermeldungen mit denen ich nicht zurecht komme.

Code:
Note: C:\Users\Jupp\Documents\NetBeansProjects\VTDESKTOP\src\main\java\org\joobsoft\vt\SYS\DataAccessClass.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Ich habe in den Properties vom Projekt nachgesehen und wollte dort unter
Build - BuildAcitions die Parameter eingeben, in der Hoffnung dann im Rahmen des Buildprozesses genauere Meldungen zu bekommen.
Da tut sich aber nichts,

ich hatte mir Build ausgewählt und unter den bereits eingetragenen Befehl build
-Xlint:deprecation eingetragen

und die anderen Parameter so gelassen
Project Relaod steht auf default.

Auch gradle meckert
Use '--warning-mode all' to show the individual deprecation warnings.

ich suche da noch die Stelle wo ich das im Gradel einbauen kann um eine Protokoll zu bekommen.
 
J

Joob

Ach so Gradel konnte ich auch auf 6.5.1 upgedated
Nach dem Update konnte ich das im Pulldown (Screenshoot oben) einfach auswählen.
Danach wurde es heruntergeladen.
 
Thema: 

Netbeans 11.1 - Gradel aktualisieren

Passende Stellenanzeigen aus deiner Region:
Anzeige

Neue Themen

Anzeige

Anzeige
Oben