Ich kann JavaFX nicht installieren

Bitte aktiviere JavaScript!
Ich habe eclipse heruntergeladen und will dort nun Java FX installieren, und zwar gemäß diesem Tuutorial:


Das geht aber nicht, denn jedes Mal kommt folgende Fehlermeldung:

Cannot complete the install because one or more required items could not be found.
Software being installed: e(fx)clipse - IDE - PDE 3.0.0.201705220750 (org.eclipse.fx.ide.pde.feature.feature.group 3.0.0.201705220750)
Missing requirement: JDT core extension for JavaFX 3.0.0.201705220750 (org.eclipse.fx.ide.jdt.core 3.0.0.201705220750) requires 'bundle org.eclipse.jdt.core 3.7.0' but it could not be found
Cannot satisfy dependency:
From: e(fx)clipse - IDE - Basic 3.0.0.201705220750 (org.eclipse.fx.ide.basic.feature.feature.group 3.0.0.201705220750)
To: org.eclipse.fx.ide.jdt.core [3.0.0.201705220750]
Cannot satisfy dependency:
From: e(fx)clipse - IDE - PDE 3.0.0.201705220750 (org.eclipse.fx.ide.pde.feature.feature.group 3.0.0.201705220750)
To: org.eclipse.fx.ide.basic.feature.feature.group 0.0.0
Gibt es da eine Lösung?
 
A

Anzeige




Vielleicht hilft dir unser Kurs hier weiter —> (hier klicken)
Ich habe jetzt mal eine vorkonfigurierte Eclipse-Version runtergeladen. Leider braucht diese java 8, das ich icht installieren kann. Ich wollte dieser Anleitung folgen:


Beim vorletzten Schritt, also wenn ich sudo apt install oracle-java8-installer eingebe, kommt folgende Fehlermeldung:
Paket oracle-java8-installer kann nicht gefunden werden.

Gibt es da eine Lösung?
 
Das Problem ist, dass der Andrew vom WebUpt8Team, seine Repos scheinbar nur noch "am Leben hält" - auf seiner Seite ist es leider absolut still geworden.

Aber soweit ich das sehe, kann man JavaFX 11 oder 12 schon noch in Eclipse - und e(fx)clipse nutzen. Auf der OpenJFX-Seite gibt es doch eine Eclipse-spezifische Anleitung:
https://openjfx.io/openjfx-docs/
 
Passende Stellenanzeigen aus deiner Region:

Neue Themen

Oben