• Wir präsentieren Dir heute ein Stellenangebot für einen Java Entwickler - m/w/d in Augsburg, München, Stuttgart oder Bamberg. Hier geht es zur Jobanzeige

Reason: Missing Constraint: Import-Package: okhttp3.internal.http; version="0.0.0"

F

Fohnbit

Top Contributor
Hallo,

ich schreibe für eine OSGi Applikation manchmal einige kleine Tools.

Nun habe ich das problem, scheinbar nach dem einfügen der Apache Client und Apache core, das am kleinen MiniPC eine Abhängigkeit fehlt:
Reason: Missing Constraint: Import-Package: okhttp3.internal.http; version="0.0.0"

Aber okhttp3 nutze ich nirgends. Ich nutze Apache.

Ich denk die letzte Erweiterung war bei:
Java:
    private String sendGet(String url) throws Exception {

        HttpGet request = new HttpGet(url);

        try (CloseableHttpResponse response = httpClient.execute(request)) {
            HttpEntity entity = response.getEntity();

            if (entity != null) {
                String result = EntityUtils.toString(entity);
                return result;
            }

        }
        return null;

    }

Nur warum schmeist er mir auf dem Ziel PC eine Exception (Debian) die ich in Eclipse auf meinem Windows nicht habe?
 

Ähnliche Java Themen

Anzeige

Neue Themen


Oben