netbeans 12 - wie -Xlint:deprecation aktivieren

Diskutiere netbeans 12 - wie -Xlint:deprecation aktivieren im IDEs und Tools Bereich.
J

Joob

Ich habe seit gestern netbeans 12
Beim clean and build bekomme ich zwei Meldungen hinsichtlich von veralteten API s.

Leider finde ich keinen Hinweis wie ich diese Parameter beim kompilieren hinzufügen kann.

1595331753877.png

1595331779437.png

So hab ich es bisher versucht, leider zeigt das gar keinen Erfolg.

Kann mir jemand sagen was ich falsch mache .
 
T

thecain

Wieso willst du das denn? Du könntest ja auch die veralteten APIs ersetzen, da Java 14 kein LTS ist, macht das auf jeden Fall Sinn
 
J

Joob

Dafür müsste ich erst einmal wissen welche das sind.
Ich habe gedacht das ich beim compilieren durch Einsatz der Parameter einen Hinweis bekomme.

Ich gehe mal davon aus das das nicht so ist.

Kannst du mir sagen wie ich die veralteten api identifizieren kann ?
 
J

Joob

Ich hab eine Lösung.
Weil es ein gradle builder hat, muss man es im Gradle build einbauen.

Code:
allprojects { // Projects
//   gradle.projectsEvaluated {
//      tasks.withType(JavaCompile) {
//         options.encoding = 'UTF-8'
//         options.compilerArgs << "-Xlint:unchecked" << "-Xlint:deprecation"
//      }
//   }
//}
so läufts dann auch.
 
Thema: 

netbeans 12 - wie -Xlint:deprecation aktivieren

Passende Stellenanzeigen aus deiner Region:
Anzeige

Neue Themen

Anzeige

Anzeige
Oben