Minecraft Spigot Server akzeptiert JAR-Version nicht

Diskutiere Minecraft Spigot Server akzeptiert JAR-Version nicht im Plattformprogrammierung Bereich.

Wie gut kennt ihr euch mit Java aus?

  • Gar nicht

  • Nicht so gut

  • Relativ gut (Mitte)

  • Gut

  • Sehr gut

  • Bester der Welt


Die Ergebnisse sind erst nach der Abstimmung einsehbar.
JeremyStarTM

JeremyStarTM

Hallo Leute!

Ich programmiere gerade ein Plugin für meinen Minecraft Spigot 1.12.0 Server.
Ich hatte gerade erst den Startprozess geschrieben. Und als ich es ausprobieren wollte passierte der Fehler in der Konsole meines Minecraft-Servers:

Code:
[11:38:41 ERROR]: Could not load 'plugins\StarMC.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: js/starmc/Main has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:326) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:248) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:298) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.reload(CraftServer.java:743) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.Bukkit.reload(Bukkit.java:525) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:641) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchServerCommand(CraftServer.java:627) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at net.minecraft.server.v1_12_R1.DedicatedServer.aP(DedicatedServer.java:443) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]
Caused by: java.lang.UnsupportedClassVersionError: js/starmc/Main has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_241]
        at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.8.0_241]
        at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.8.0_241]
        at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.8.0_241]
        at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.8.0_241]
        at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.8.0_241]
        at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.8.0_241]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_241]
        at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_241]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_241]
        at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_241]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[spigot-1.12.jar:git-Spigot-596221b-9a1fc1e]
        ... 14 more
PS: Ich programmiere in Eclipse Enterprise for Java Developers - Version: 2019-12 (4.14.0 - Build: 20191212-1212

Könnte mir da einer helfen?

Danke schon mal im voraus,
2020 JeremyStar
 
mihe7

mihe7

Die Meldung
Caused by: java.lang.UnsupportedClassVersionError: js/starmc/Main has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0
ist ziemlich eindeutig: Du verwendest zum Kompilieren ein JDK 13, zum Ausführen aber Java 8.
 
JeremyStarTM

JeremyStarTM

Die Meldung

ist ziemlich eindeutig: Du verwendest zum Kompilieren ein JDK 13, zum Ausführen aber Java 8.
Danke @mihe7. Kenne mich noch nicht so gut aus mit diesen Fehlern. Ich weiß da nur wie man das Plugin startet, Befehle ausführt und ein paar Sachen mehr. Aber noch lange nicht alles. Aber, wie kann ich das beheben?
 
A

abc66

Also deinstalliere alle Java Versionen und dann installiere dieselbe Version des JDK und JRE... Anschließend sollte der Konflikt nicht mehr auftreten.
 
JeremyStarTM

JeremyStarTM

Also deinstalliere alle Java Versionen und dann installiere dieselbe Version des JDK und JRE... Anschließend sollte der Konflikt nicht mehr auftreten.
Ich habe gerade schon versucht den Compiler in den Propeties von 13 zu 1.8 zu setzen. Hat funktioniert. Naja, trotzdem danke an alle. Und @abc66, könnte ich gar nicht machen wegen dem Minecraft Launcher.


DANKE FÜR EURE ANTWORTEN,
2020 JEREMYSTAR
 
mihe7

mihe7

@abc66 warst Du das mit Deinen drei Accounts oder hat da wirklich jemand auf "Jetzt abstimmen" gedrückt?
 
A

abc66

Ich hab nix verfälscht... Ich hab lediglich für mich abgestimmt. :)
 
Thema: 

Minecraft Spigot Server akzeptiert JAR-Version nicht

Passende Stellenanzeigen aus deiner Region:
Anzeige

Neue Themen

Anzeige

Anzeige
Oben