Gradle sync failed: Could not determine Java version using executable

M

marlem

Bekanntes Mitglied
Hallo,

beim öffnen eines anderen Projekts taucht jetzt diese Fehlermeldung auf:

12.04.2020
21:41 Gradle sync started

21:41 Gradle sync failed: Could not determine Java version using executable C:\Program Files\Java\jdk-13.0.2\bin\java.exe.
The project uses Gradle 2.8 which is incompatible with Java 10 or newer.
See details at https://github.com/gradle/gradle/issues/4503
Possible solution:
- Upgrade Gradle wrapper to 4.8.1 version and re-import the project
Consult IDE log for more details (Help | Show Log) (777 ms)

Frage:
Muss ich jetzt Java 9 installieren und Android dazu bringen, dass er mit Java 9 compiliert?
 
kneitzel

kneitzel

Top Contributor
Das Projekt nutzt eine uralt Version von gradle. Du könntest gradle aktualisieren. So es ein gradle wrapper nutzt, wäre das ein Eintrag in der Datei
gradle/wrapper/gradle-wrapper.properties
Da ist dann wohl eine Zeile wie diese hier vorhanden:
distributionUrl=https\://services.gradle.org/distributions/gradle-6.0-all.zip
(Nur eben mit 2.7 als Version)

Danach muss evtl. noch etwas in der build.gradle verändert werden...

Oder man nutzt tatsächlich eine Java Version 9.
 
M

marlem

Bekanntes Mitglied
Es gibt eine Wrapper-Property die ich habe ich aktualisiert:
distributionUrl=https\://services.gradle.org/distributions/gradle-6.0-all.zip

Dann habe ich gradlw aufgerufen jetzt kommt diese Fehlermeldung:
12.04.2020
21:41 Gradle sync started

21:41 Gradle sync failed: Could not determine Java version using executable C:\Program Files\Java\jdk-13.0.2\bin\java.exe.
The project uses Gradle 2.8 which is incompatible with Java 10 or newer.
See details at https://github.com/gradle/gradle/issues/4503
Possible solution:
- Upgrade Gradle wrapper to 4.8.1 version and re-import the project
Consult IDE log for more details (Help | Show Log) (777 ms)

22:14 Gradle sync started

22:16 Gradle sync failed: Cause: invalid type code: 4F
Consult IDE log for more details (Help | Show Log) (1 m 34 s 664 ms)

in der log-datei steht das hier:
2020-04-12 22:16:06,969 [5872922] INFO - roid.tools.ndk.GradleWorkspace - Updating model took 0.002s
2020-04-12 22:16:07,252 [5873205] INFO - ge.ExternalProjectsDataStorage - Save external projects data in 9 ms
2020-04-12 22:17:43,918 [5969871] INFO - ide.actions.ShowFilePathAction -
Exit code 1
2020-04-12 22:24:22,507 [6368460] INFO - rationStore.ComponentStoreImpl - Saving appGeneralSettings took 13 ms
2020-04-12 22:26:46,027 [6511980] INFO - ide.actions.ShowFilePathAction -
Exit code 1
2020-04-12 22:26:47,504 [6513457] INFO - mponents.impl.stores.StoreUtil - saveProjectsAndApp took 174 ms

Was muß ich tun?
 
kneitzel

kneitzel

Top Contributor
Im Verzeichnis des Projekts ist eine batch Datei Gradle.bat. Einfach in einer Eingabeaufforderung in das Verzeichnis des Projekts gehen und dann die batch Datei aufrufen.
 
Anzeige

Neue Themen


Oben