Compiler-Fehler Eclipse Error: A JNI error has occured

Diskutiere Eclipse Error: A JNI error has occured im Allgemeine Java-Themen Forum; Hallo, ich programmiere gerade ein Programm in Eclipse und bekomme beim Ausführen die Fehlermeldung ,,Error: A JNI error has occured, please check...

  1. lucab
    lucab Neues Mitglied
    Hallo, ich programmiere gerade ein Programm in Eclipse und bekomme beim Ausführen die Fehlermeldung ,,Error: A JNI error has occured, please check your Installation and try again."
    Alle meine anderen Programme kann ich noch ausführen, nur dieses eine nicht. Im Programmcode zeigt der Compiler keinen Fehler an.

    Das Programm um das es geht speichere ich immer bei Github in einem Repository, hängt der Fehler eventuell damit zusammen?

    In der Konsole kommt außerdem die Fehlermeldung:
    Exception in thread "main" java.lang.UnsupportedClassVersionError: Klassenname has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

    Vielen Dank im Voraus.
    LG
     
  2. Vielleicht hilft dir dieses Training hier weiter.
  3. mrBrown
    mrBrown Super-Moderator Mitarbeiter
    In der Exception steht der relevante Punkt:

    Du kompilierst mit Java 10, führst aber mit Java 8 aus.
     
  4. lucab
    lucab Neues Mitglied
    Danke schon mal, weißt du, wie ich das ändern kann?
     
  5. mrBrown
    mrBrown Super-Moderator Mitarbeiter
    Naja, entweder für Java 8 kompilieren oder mit Java 10 ausführen...

    Ersteres lässt sich sicher irgendwo in Eclipse einstellen, wo kann ich dir leider nicht sagen
     
  6. Wenn du Java lernen möchtest, empfehlen wir dir diese Online-Training hier
Die Seite wird geladen...

Eclipse Error: A JNI error has occured - Ähnliche Themen

Eclipse IDE Plugin Error Log
Eclipse IDE Plugin Error Log im Forum Allgemeine Java-Themen
Error: Could not find or load main class xyz (Eclipse)
Error: Could not find or load main class xyz (Eclipse) im Forum IDEs und Tools
Dll einbinden java.lang.UnsatisfiedLinkError nur in Eclipse nicht via javac
Dll einbinden java.lang.UnsatisfiedLinkError nur in Eclipse nicht via javac im Forum Allgemeine Java-Themen
Eclipse zeigt keine Errors an!
Eclipse zeigt keine Errors an! im Forum IDEs und Tools
Error_GWT GUI Designer Eclipse(Mars)
Error_GWT GUI Designer Eclipse(Mars) im Forum IDEs und Tools
Thema: Eclipse Error: A JNI error has occured

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. eclipse jni error

    ,
  2. eclipse error occured