Kein Zugriff auf die Anwendung nach Deployment Glassfish

Diskutiere Kein Zugriff auf die Anwendung nach Deployment Glassfish im Server einrichten und konfigurieren Forum; Hallo zusammen, Wenn ich die Domain starte, dann ist der Server über localhost::8080, 127.0.0.1:8080 und valentin-laptop:8080 erreichbar. Die...

  1. MARJAVA
    MARJAVA Mitglied
    Ich habe mich deshalb in diesem Thread geäußert weil bei mir der gleiche Fehler ,Fehler 404, auftritt, wenn ich die Links benutze.
    Allerdings liegt die index.html bereits im richtigen Verzeichnis. Der Unterschied zu meinem Fehler ist, dass ich das Deployment und den Domainstart mit eclipse vorgenommen habe.
     
  2. mihe7
    mihe7 Aktives Mitglied
    Naja, damit wir da weiter kommen müsstest Du die Frage von @mrBrown beantworten.
     
  3. MARJAVA
    MARJAVA Mitglied
    Dachte ich habe die Frage mit dem Post der Zeilen des HTML-Files beantwortet. Es ist nur eine HTML-Seite die die Überschrift Onlineshop trägt und im Body "Onlinshop" zu lesen ist. Mehr bietet das Beispiel nicht.
    Beantwortet das die Frage?

    mhhh hab den Fehler entdeckt.
    In meiner index.html fehlte beim charset ein "/".

    Ich sollte wohl eine IDE für HTML-files nutzen, denn ist sicher ein alltägliches Problem. Falls jemand eine gute kennt, bitte posten.
    Ärgerlich nur, dass die Seite im Browser ohne Probleme angezeigt wurde, deshalb ging ich davon aus dass sie korrekt ist.
     
  4. mrBrown
    mrBrown Super-Moderator Mitarbeiter
    Und der Fehler tritt auch wieder auf, wenn du nur dieses eine '/' wieder entfernst?

    Eigentlich sollte der Inhalt der Html-Datei nicht für solche Fehler sorgen...

    Der '/' im meta-Tag für das Charset in obiger Html-Datei ist btw. fehlerhafter als ein an der Stelle fehlender '/'. Deshalb würde mich er erst Recht wundern, wenn ein Webserver das falsche ausliefert, aber das richtige nicht.
    Oder sieht deine Html-Datei anders aus?
     
    Zuletzt bearbeitet: 13. Juli 2018
  5. MARJAVA
    MARJAVA Mitglied
    Nachdem ich es wieder entfernt habe läuft es trotzdem. Das war aber das einzige was ich verändert habe, bevor es lief.
    Bevor ich das slash einfügte, wurde die html-seite garnicht angezeigt bzw. jetzt sieht sie genauso aus.
     
  6. mrBrown
    mrBrown Super-Moderator Mitarbeiter
    Dann wird es nicht an dem Slash, sondern an irgendwas anderem gelegen haben ;)
     
Die Seite wird geladen...

Kein Zugriff auf die Anwendung nach Deployment Glassfish - Ähnliche Themen

Java hat keinen Zugriff auf MySQL
Java hat keinen Zugriff auf MySQL im Forum Datenbankprogrammierung
Kein Zugriff auf Telefonspeicher (Android 6)
Kein Zugriff auf Telefonspeicher (Android 6) im Forum Mobile Geräte
Eclipse: JBoss Hibernate Tool: Kein Zugriff auf Datenbank
Eclipse: JBoss Hibernate Tool: Kein Zugriff auf Datenbank im Forum Datenbankprogrammierung
VlCJ Windows 10 kein Zugriff auf einen im Netzwerk freigegebnen Ordner
VlCJ Windows 10 kein Zugriff auf einen im Netzwerk freigegebnen Ordner im Forum Spiele- und Multimedia-Programmierung
Deployment kein zugriff auf Web-inf tomcat 8 und 7
Deployment kein zugriff auf Web-inf tomcat 8 und 7 im Forum Deployment
Thema: Kein Zugriff auf die Anwendung nach Deployment Glassfish