JPanel lädt nicht?!

Ich muss sagen so langsam geht mir dieses (anfangs) al klein vermutete Problem auf die nerven -.-
Aber dir vielen dank für die Hilfe! und wenn du dich da nicht mal so mit auskennst doppelt dank das du es versucht hast!!
Das Problem ist nicht schwer zu lösen. Ich verwende nur kein Eclipse, daher kann ich Dir nicht auswendig sagen, wo Eclipse Deine Ressourcen erwartet - anscheinend nirgends und Du musst den Resource-Folder selbst hinzufügen. Hinzu kommt, dass Du in der IDEs beim Anlegen eines neues Projekts angeben kannst, welches Build-System verwendet werden soll.

Mal als Beispiel: wenn Du in NetBeans ein "normales Java-Projekt" erzeugst, wird ant als Buildsystem verwendet und alles (auch Ressourcen), was sich unter src befindet, wird in das Jar gepackt. Im alten Eclipse meine ich mich erinnern zu können, dass das dort auch der Fall war. Daher habe ich geschrieben, Du sollst mal versuchen, den images-Ordner nach src zu verschieben.

Erstellst Du dagegen (ebenfalls mit NetBeans oder Eclipse) ein Maven-Projekt, dann wird - tada - maven als Buildsystem verwendet. Maven hat eine etwas andere Verzeichnisstruktur (per Konvention). Die Java-Dateien befindet sich unter src/main/java und alle Ressourcen, die sich dort befinden, werden beim Zusammenpacken des Jars ignoriert. Die müssen dann nämlich unter src/main/resources gespeichert werden.

Ich habe jetzt eine alte Eclipse-Version aufgerufen. Du klickst mit der rechten Maustaste auf Dein Projekt, öffnest im Kontextmenü den Punkt "Build Path" und wählst dort "New Source Folder" aus. Dort gibst Du einen Namen, sagen wir mal "resources" an. Anschließend verschiebst Du Deinen images-Ordner in den resources-Ordner. Wenn Du dann das Jar baust, sollte der images-Ordner enthalten sein.
 
Passende Stellenanzeigen aus deiner Region:

Neue Themen

Oben