Java-Programme starten nicht

Bitte aktiviere JavaScript!
Status
Nicht offen für weitere Antworten.
Hallo an alle,

hab ein Problem und das hängt offensichtlich iwie mit Java zusammen.
Wenn ich bestimmte Programme starten möchte die auf Java basieren (zb sqldeveloper, hattrickorganizer oder netbeans), dann gibts Probleme.
Und zwar: doppelklick auf Programm:Taskleiste verschwindet für einen Moment, das System hängt für ~5-10Sekunden, danach ist alles wieder da nur das Programm startet eben nicht und die geöffneten Windows-Ordner sind alle weg. (das is nicht das Problem aber ich wollte es es nur anmerken)
Hab gerade eben alle Java-Developments kits und Runtimes die sich in den letzten Jahren gesammelt haben gelöscht und die neueste Runtime installiert und neugestartet.
Ausprobiert - leider keine Veränderung zu vorher :/

Was tun, was kann schuld sein?
Es ist relativ dringend, denn ich muss ja mit den Programmen arbeiten.

ps: mein System: Windows XP SP3
 
A

Anzeige


Vielleicht hilft dir dieser Kurs hier weiter: (hier klicken)
Wie reagiert das System auf eine einfache Versionsabfrage, und was gibt es dabei aus?
Code:
java -version
Ark
 
wie folgt:

java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode, sharing)

Hab die Umgebungsvariable vorher schon geändert, d.h. die alte raus und ersetzt durch die neue bei JAVA_Home und bei Systemvariable.
 
Ist die Taskleiste dabei verschwunden? So, wie es aussieht, ist dir explorer.exe abgestürzt. Bist du dir sicher, dass die anderen Programme wissen, wo du deine aktuelle JVM bereithältst? Vielleicht werden sie über ein Skript gestartet, das von deinem Umbau nichts mitbekommen hat. Probiere ein kleines Hallo-Welt-Programm aus. Was passiert da?

Ark
 
Ist die Taskleiste dabei verschwunden?
Nein, alles normal.
Übrigens bei Ausführen - regedit verschwindet sie aber auch, warum auch immer...

So, wie es aussieht, ist dir explorer.exe abgestürzt. Bist du dir sicher, dass die anderen Programme wissen, wo du deine aktuelle JVM bereithältst? Vielleicht werden sie über ein Skript gestartet, das von deinem Umbau nichts mitbekommen hat. Probiere ein kleines Hallo-Welt-Programm aus. Was passiert da?

Ark
Hmmm mal für langsame und schon etwas Verwirrte:

Also was ich bisher tat: in System - Umgebungsvariable:
bei Benutzervariable: JAVA_Home: alter EIntrag weg und ersetzt durch C:\Programme\Java\jdk1.6.0_14

bei Systemvariable: inPath: alter Eintrag weg und ersetzt durch C:\Programme\Java\jre6\bin

bei Classpath: hab ich nichts getan, steht noch die alte C:\Programme\Java\jre1.5.0_06; löschen und durch neue ersetzen oder neue einfach hinzu und alte lassen?

Skript hab ich nihct zum Starten der Progs. Und ja du hast Recht - Hello World startet nicht^^


Mir raucht schon der Schädel von dem ganzen! ;)
 
Wie? Auch bei einem einfachen regedit stürzt explorer ab? Kann es sein, dass mit deinem System grundsätzlich etwas nicht stimmt? ^^

Ark
 
anscheinend^^ das mitn regedit hab ich auch gerade erst entdeckt.

sag mal ob das mit den Umgebungsvariablen so gepasst hat?
Was soll ich tun? Neu aufsetzten würd ich nur zu ungern :eek:
 
Das sind wieder so Momente, wo ich mir denke: "Mit Linux wär' das nicht passiert!" :D

Ehrlich, ich benutze ja mein GNU/Linux erst seit *nachzähl* 21 Monaten produktiv, aber mir ist noch nie der Fall untergekommen, dass das System ohne irgendeinen ersichtlichen oder nachvollziehbaren Grund ganz oder in Teilen plötzlich nicht mehr funktioniert oder verrückt spielt.

Weiterhelfen kann ich dir, wie du siehst, nicht mehr wirklich ... außer natürlich, dich zu einem Umstieg zu bewegen, der einen Abschied von der Windows-Welt bedeutet. ;)

Ein Hoch auf unixoide Systeme. :toll:

EDIT: Eine nette Grafik, die ich bei solchen Themen gerne anführe: top500.org. Das soll was heißen. :smoke:

Ark
 
Zuletzt bearbeitet:
@Ark
Jepp, Linux kann ich nur jedem empfehlen ;)

Für mich hört sich das nach was gröberem an. Am besten du setzt dein System neu auf, wahrscheinlich wurde dass eh schon seit über einem Jahr nicht mehr neu aufgesetzt. Ein Tipp installier dir diesesmal kein SP3 mehr dazu, das macht selbst jetzt noch Scherereien! SP2 ist völlig ausreichend.
 
Hm ich hoffe noch schnell iwie ne andere Lösung zu finden - denn kurz vor
meinen Prüfungen würde ich nur ungern alle Programme wieder installieren und konfigurieren wollen...
Weiss aber momentan auch nicht wie ich das seltsame Problem lösen sollte....;(
 
Gehe mal in die Systemsteuerung -> (falls da: Leistung und Wartung) -> Verwaltung -> Ereignisanzeige

die Listen löschst du erstmal (da du es vermutlich nie gemacht hast wird es sonst sehr unübersichtlich, die neuen Einträge kommen schnell genug.

Danach schliesse die Ereignisanzeige, starte 2, 3 Programme und schaue mal wieder was dann an Fehlern in der Ereignisanzeige auftaucht

am Interessantesten sollten die Listen System und Anwendung sein

und PS: Linux ist oft genial, aber das letze mal das Win neu installiert werden musste war bei mir der Rechnerwechsel und davor WinXP ohne ServicePack (weil vor Zeiten des SP)
unter Windows kann man ebenfalls gut arbeiten...
 
Gehe mal in die Systemsteuerung -> (falls da: Leistung und Wartung) -> Verwaltung -> Ereignisanzeige

die Listen löschst du erstmal (da du es vermutlich nie gemacht hast wird es sonst sehr unübersichtlich, die neuen Einträge kommen schnell genug.

Danach schliesse die Ereignisanzeige, starte 2, 3 Programme und schaue mal wieder was dann an Fehlern in der Ereignisanzeige auftaucht

am Interessantesten sollten die Listen System und Anwendung sein

und PS: Linux ist oft genial, aber das letze mal das Win neu installiert werden musste war bei mir der Rechnerwechsel und davor WinXP ohne ServicePack (weil vor Zeiten des SP)
unter Windows kann man ebenfalls gut arbeiten...
Ok wenn ich dann ein java-programm a la dqldeveloper starte kommt in der Ereignismeldung:

"Die Shell wurde unerwartet beendet und explorer.exe wurde neu gestartet.
Ereigniskennung:1002
Quelle:Winlogon"
 
Sind da noch mehr Fehler? dieser Fehler ist leider ziemlich nichtssagend, schau mal 2, 3 Einträge darüber und darunter
 
bei Anwendungen steht sonst nichts - das einzige Ereignis das auftritt.

bei System steht aber ~20Sekunden nach dem Starten des Java-Programms(also in der Zeit während die explorer.exe neu lädt) immer folgendes:

Obiges geschildertes Ereignis: 18:36:36

3 Ereignisse in System:
Uhrzeit: 18:37:07
Der Steuerbefehl "starten" wurde erfolgreich an den Dienst "IMAPI-CD-Brenn-COM-Dienste" gesendet.
Ereigniscode: 7035
Quelle: Service Control Manager

Uhrzeit: 18:37:07
"Dienst "IMAPI-CD-Brenn-COM-Dienste" befindet sich jetzt im Status "Ausgeführt".
Ereigniscode: 7036
Quelle: Service Control Manager

Uhrzeit: 18:37:14
Dienst "IMAPI-CD-Brenn-COM-Dienste" befindet sich jetzt im Status "Beendet".
Ereigniscode: 7036
Quelle: Service Control Manager
 
Status
Nicht offen für weitere Antworten.
Passende Stellenanzeigen aus deiner Region:

Neue Themen

Oben