WebDAV mit Windows

Dieses Thema WebDAV mit Windows im Forum "Web Tier" wurde erstellt von scMember, 22. Apr. 2015.

Thema: WebDAV mit Windows Guten Tag zusammen, seit Tagen versuche ich nun den Explorer (über Netzlaufwerk verbinden->Eine Netzwerkadresse...

  1. Guten Tag zusammen,

    seit Tagen versuche ich nun den Explorer (über Netzlaufwerk verbinden->Eine Netzwerkadresse hinzufügen) mit dem Apache Tomcat und einem einfachen WebDAV zu verbinden; Ohne Erfolg.
    Ich habe eine einfache Basic Authentifikation, ohne viel Schnick Schnack (ist schliesslich nur für intern). Die entsprechenden Registry Einträge habe ich auch bereits angepasst.
    Sprich: BasicAuthLevel=2
    Das einzige was nicht ist; Der Request geht nicht an einen http(s), sondern nur an einen http.
    Der Request von Windows sieht so aus:

    PROPFIND /myPool/pool HTTP/1.1
    Connection: Keep-Alive
    User-Agent: Microsoft-WebDAV-MiniRedir/6.1.7601
    Depth: 0
    translate: f
    <hier steht die Basic Authetifizierung>


    Meine Antwort auf dieses Request lautet:

    HTTP/1.1 207 Multi-Status
    Server: Apache-Coyote/1.1
    Content-Location: http://<Internetadresse>:8080/myPool/pool/
    Content-Type: text/xml;charset=utf-8
    Transfer-Encoding: chunked
    Date: Wed, 22 Apr 2015 10:13:19 GMT

    <?xml version="1.0" encoding="UTF-8"?>

    <multistatus xmlns="DAV:">
    <response>
    <href>http://<Internetadresse>:8080/isb300/pool/</href>
    <propstat>
    <prop>
    <resourcetype>
    <collection/>
    </resourcetype>
    </prop>
    <status>HTTP/1.1 200 OK</status>
    </propstat>
    </response>
    </multistatus>


    Leider kommt die Abfrage nach dem Kennwort immer wieder und wieder, ohne dass Windows weitere Daten abfragt. Unter Windows XP hat es einwandfrei funktioniert.
     
  2. Vielleicht hilft dir das Java-Tutorial weiter. Hier klicken --> (Klick)